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Trinket may be small, but do not be fooled by its size! It's a tiny microcontroller board, built around the Atmel ATtiny85,
a little chip with a lot of power. We wanted to design a microcontroller board that was small enough to fit into any
project, and low cost enough to use without hesitation. Perfect for when you don't want to give up your expensive dev-
board and you aren't willing to take apart the project you worked so hard to design. It's our lowest-cost arduino-IDE
programmable board!

The Attiny85 is a fun processor because despite being so small, it has 8K of flash, and 5 I/O pins, including analog
inputs and PWM 'analog' outputs. We designed a USB bootloader so you can plug it into any computer and reprogram
it over a USB port just like an Arduino. In fact we even made some simple modifications to the Arduino IDE so that it
works like a mini-Arduino board. You can't stack a big shield on it but for many small & simple projects the Trinket will
be your go-to platform.

Even though you can program Trinket using the Arduino IDE, it's not a fully 100% Arduino-compatible. There are some
things you trade off for such a small and low cost microcontroller!

e Trinket does not have a Serial port connection for debugging so the serial port monitor will not be able to
send/receive data

® Some computers' USB v3 ports don't recognize the Trinket's bootloader. Simply use a USB v2 port or a USB hub
in between

There are two versions of the Trinket. One is 3V and one is 5V. Both work the same, but have different operating logic
voltages. Use the 3V one to interface with sensors and devices that need 3V logic, or when you want to power it off of
a LiPo battery. The 3V version should only run at 8 MHz. Use the 5V one for sensors and components that can use or

require 5V logic. The 5V version can run at 8 MHz or at 16MHz by setting the software-set clock frequency.

Here are some useful specifications!
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e ATtiny85 on-board, 8K of flash, 512 byte of SRAM, 512 bytes of EEPROM

® [nternal oscillator runs at 8MHz, but can be doubled in software for 16MHz

e USB bootloader with a nice LED indicator looks just like a USBtinyISP so you can program it with AVRdude
(with a simple config modification) and/or the Arduino IDE (with a few simple config modifications)

e Mini or Micro-B USB jack for power and/or USB uploading, you can put it in a box or tape it up and use any USB
cable for when you want to reprogram.

o We really worked hard on the bootloader process to make it rugged and foolproof, this board wont up and die
on you in the middle of a project!

e ~5.25K bytes available for use (2.75K taken for the bootloader)

e Available in both 3V and 5V flavors

e On-board 3.3V or 5.0V power regulator with 150mA output capability and ultra-low dropout. Up to 16V input,
reverse-polarity protection, thermal and current-limit protection.

e Power with either USB or external output (such as a battery) - it'll automatically switch over

e On-board green power LED and red pin #1 LED

e Reset button for entering the bootloader or restarting the program. No need to unplug/replug the board every
time you want to reset or update!

® 5 GPIO - 2 shared with the USB interface. The 3 independent IO pins have 1 analog input and 2 PWM output as
well. The 2 shared 10 pins have 2 more analog inputs and one more PWM output.

e Hardware 12C / SPI capability for breakout & sensor interfacing.

e Mounting holes! Yeah!

TRINKET 5V

GROUND
USB 5V 500mA

ANALOG: [[T33] WRITE|

DI -SDA
DO -LED
SCK PORTPIN

5V 150mA l Misc

Trinket Sv
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Guided Tour
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Let me take you on a tour of your Trinket! Each trinket is assembled here at Adafruit and comes chock-full of good
design to make it a joy to use.

e Mini-B USB connector - We went with the tried and true mini-B USB connector for power and/or USB
bootloading. In our experience, Micro-B connectors can rip off the PCB easily, but we have not had that problem
with mini B, its much more rugged for DIY electronics. It's also a proper USB connector, so you can use any
length cable. Some Attiny85 boards use a PCB that slides into a USB port to cut costs, but that makes it hard to
re-program and annoying to power with an external battery pack

e Green Power LED - you'll know that the board is powered up when this bright LED is lit

e Red #1LED - this LED does double duty. Its connected with a series resistor to the digital #1 GPIO pin. It pulses
nicely when the Trinket is in bootloader mode, and its also handy for when you want an indicator LED.

e Battery + Input - take your Trinket anywhere and power it from an external battery. This pin can take up 16V DC
input, and has reverse-polarity, over-curent and thermal protections. The circuitry inside will use either the
battery or USB power, safely switching from one to the other. If both are connected, it will use whichever has the
higher voltage

e USB Power Output - You can also snhag the 5V power from the USB jack in case you need 500mA+ current from
your computer or portable USB power pack.

® Breadboard friendly pins - You can easily plug this into a little breadboard and have plenty of space for working
and plugging stuff in

e GPIO!- 5 GPIO pins, at 3 or 5V logic, check the next section for a detailed pinout guide

e 3 or 5V output - an onboard regulator provides 3.3V or 5V output for powering LEDs, sensors, small motors, etc.

® Reset Button - an onboard reset button will launch the bootloader when pressed and the Trinket is plugged into
a computer. If it is not connected to a computer, it's smart enough to go straight to the program.

e External Reset Pin - we bring out the reset pin so you can reset or restart your Trinket on the road. If the Trinket
is in a box or otherwise hard to get to, you can wire up a button to this pin for an external reset button.

e Four mounting holes make it easy to attach with 2mm screws or even tiny zip-ties, string, etc.
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Pinouts

There are two versions of the Trinket: 3V and 5V. They are almost identical but there are slight differences in
the pinouts: one has a 3V output pin in the bottom right, the other has a 5V output pin instead

Jrinket 3v B ‘\Tnnket 5v

GROUND

i 5.5-16V BATTERY 0* DIGITAL READ/WRITE
GROUND ANALOG: [[T33] WRITE|
PORTPIN

Misc

Trinket Sv
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digitalRead() and digitalWrite()

Pinout Diagram

(3.3V version)

FC (TWI)

4316V satreRy  {@%: 573
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Here's the ATtiny85 pinout

N
(PCINTS/RESET/ADCO/dW) PBS ] 1 8 vcc
(PCINT3/XTAL1/CLKI/OC1B/ADC3) PB3 [] 2 7 | PB2 (SCK/USCK/SCL/ADCT/TO/INTO/PCINT2)
(PCINT4/XTALZ/CLKO/OCTIB/ADC2) PB4 [] 3 6 1 PB1 (MISC/DO/AINT/OCOB/OCTA/PCINTI)
GND ] 4 5|2 PBO {MDSIIDIISDAIAIND.FOCGMWAREF!PCINTGH

Power Pins

We'll start with the top pins BAT+ and USB+ and GND

e BAT+ is the Battery + Input pin. If you want to power the trinket from a battery or power adapter or solar panel or
any other kind of power source, connect the + (positive) pin here! You can connect up to 16V DC. If you have a
3V Trinket, you'll want at least 3.5V input to get a good 3.3V output. If you have a 5V trinket, 5.5V or higher is
suggested. This input is reverse-polarity protected.

e USB+is the USB + Output pin. If you want to use the USB 5V power for something, like charging a battery, or if
you need more than 150mA of current (this pin can supply 500mA+ from USB ports) or to detect when the
Trinket is plugged into USB, this pin will have 5V power on it if and only if its plugged into something via the mini
B connector

e GND is the common ground pin, used for logic and power. It is connected to the USB ground and the power
regulator, etc. This is the pin you'll want to use for any and all ground connections

GPIO Pins

Next we will cover the 5 GPIO (General Purpose Input Ouput) pins! For reference you may want to also check out the
datasheet-reference above for the core ATtiny85 pin

All the GPIO pins can be used as digital inputs, digital outputs, for LEDs, buttons and switches etc. They can provide up

to 20mA of current. Don't connect a motor or other high-power component directly to the pins! Instead, use a transistor
to power the DC motor on/off
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On a 3V Trinket, the GPIO are 3.3V output level, and should not be used with 5V inputs. On a 5V Trinket, the GPIO are
5V output level, and can be used with 3V inputs but may damage electronic devices that are 3V input only!

The first 3 pins are completely 'free' pins, they are not used by the USB connection so you never have to worry about
the USB interface interfering with them when programming

e GPIO #0 - this is connected to PBO on the ATtiny85. This pin can be used as a PWM output, and is also used for
I2C data, and SPI data input.

e GPIO #1 - this is connected to PB1 on the ATtiny85. This pin can be used as a PWM output, and is also used for
SPI data output. This pin is also connected to the onboard LED (like pin 13 on a regular Arduino).

e GPIO #2 - this is connected to PB2 on the ATtiny85. This pin can be used as an analog input (known as Analog
A1), and is also used for 12C clock and SPI clock.

USB Pins

The next 2 pins are also used for USB programming. That means that when the Trinket is connected to a computer
and in bootloader mode or in the middle of uploading a new program, they are used for sending data to/from the
computer! It's possible to share these pins if you are careful. The best use of these pins is as outputs to things like
LEDs. We didn't want to keep these pins off the board but we strongly recommend not using them unless you're sure
you need them since you might have to disconnect any connections to reprogram the Trinket!

e GPIO #3 - this is connected to PB3 on the Attiny85. This pin is used for USB programming, but its also an analog
input known as Analog A3
This pin has a 1.5K pullup to 3.3V built into the Trinket, for USB comm so it may be difficult to use for analog or
digital input.

® GPIO #4 - this is connected to PB4 on the Attiny85. this pin is used for USB programming, but it can also be
used as a PWM analog output and an analog input known as Analog A2

Note the numbering of analog pins: Pin 2 is Analog 1, Pin 3 is Analog 3, Pin 4 is Analog 2. For the Uno, the

terms A1, A2, and A3 are mapped for you. For ATtiny85's, they are not. So for the pinMode calls, use the Pin
number (stenciled on Trinket), for analogRead, use the analog number.

Reset and Regulator Output

The final two pins are at the bottom of the board.

First is the Rst reset pin. This is connected directly to the ATtiny85's reset pin and also the reset button which is right
next to it. The reset pin is used to enter the bootloader and to reset the board in case you want to restart it. It's also
possible to use this pin to re-program in the bootloader or completely remove the bootloader if you have an AVR
programmer such as an AVR Dragon, MKii or USBtinyISP. If you want to re-program the board when its in an enclosure
or box or otherwise hard to reach, wire a simple button from the RST pin to ground and press it to enter the bootloader
for 10 seconds. The #1 LED will pulse to let you know. The reset button cannot be used as a GPIO, but we think its a lot
more useful as a proper reset button!

Lastly we have the regulator output pin. There is an onboard mini power regulator that will take up to 16V DC from the
BAT+ or USB connection and regulate it down to a steady 3.3V or 5.0V DC so its safe to use with your sensors and
LEDs. On a 3V Trinket, this output will be about 3.3V. On a 5V Trinket, this output will be 5V so be aware in case you
want to swap one with the other. You can draw up to 150mA output from this pin. If you need more current, you may
want to get it directly from the USB+ pin, which supplies 5V @ 500mA from a computer or wall adapter
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Starting the Bootloader
About the bootloader

A bootloaderis a tiny piece of software residing on the microcontroller that that helps load your own code into the
remaining space.

One of the challenges with the Trinket is that we wanted to have a built-in USB bootloader, but the ATtiny85 doesn't
have built-in USB hardware! There are existing USB bootloaders that can work on the 't85 but they use other
companies' USB VID/PIDs. Since it not permitted by the USB developer's group to use others' VID/PIDs we had to
adapt one of these existing bootloaders to use our USB ID, but we also wanted to not have to re-compile avrdude or
the Arduino IDE since that's such a pain.

So instead, Frank (our awesome engineer with mad USB chops) created a USB bootloader that combines the
elegance of V-USB with the well-supported and tested nature of the USBtinyISP. This bootloader looks just like a
USBLtinyISP - and since it uses the unique Adafruit VID/PID we own and that we added to avrdude so long ago, it works
with only very minimal configuraton tweaks. No need to recompile anything, whew!

Please note: you cannot use the Adafruit USB VID/PID for your own non-Trinket products or projects.

Purchase a USB VID for yourself at

Trinket USB Drivers for Windows

If you're using Windows be sure to follow the Windows Driver Installation page to install the appropriate drivers for your
Trinket.

For Mac OSX or Linux you don't need to install any drivers.

Special Notes on using Trinket with Linux

Trinket is not supported on Linux operating system at this time - try Mac OS or Windows! However, you can

try the following - it does work for some computers

Linux is fairly picky about who can poke and prod at the USB port. You can always runavrdude or Arduino IDE as root,
which will make sure you have the proper permissions. If you want to be super-cool you can add a udev rule which will
let any user (who is not root) connect to the USBtiny driver. That way you don't have to be root all the time!

Check http://learn.adafruit.com/usbtinyisp/avrdude#for-linux for what to add to your udev file.

How to start the bootloader

Before you try to upload code to the Trinket it must be in the Bootloader Mode. That means its listening for a sketch or
program to be sent to it
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When the Trinket is in bootloader mode, the red LED will be pulsing. Once the red LED stops pulsing, you

must press the reset button to re-enter bootloader mode

The Trinket must be connected to a computer via a USB cable to enter bootloader mode. You can enter the
bootloader mode by pressing the little button on the board with your fingernail. The bootloader will 'time out' after 10
seconds, so to re-enter the bootloader mode just re-press the button!

Don't press-and-hold the reset button, be sure to press-and-release!

See the video below for what it looks like to plug it in, have the LED pulse in bootloader mode, time out and then press
reset to restart the bootloader
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Windows Driver Installation

Mac and Linux do not require drivers, only Windows folks need to do this step

Before you plug in your board, you'll need to possibly install a driver!

Click below to download our Driver Installer.

Download Latest Adafruit Windows Driver

Installer

https://adafru.it/AON

Download and run the installer.

-
Opening adafruit_drivers.exe u

You have chosen to open:
[n"] adafruit_drivers.exe

which is: Binary File (13.6 MB}
from: https://github-cloud.s3.amazonaws.com

Would you like to save this file?

[ e ] | Cancel |

Run the installer! Since we bundle the SiLabs and FTDI drivers as well, you'll need to click through the license

-
* Adafruit Board Drivers:gcense Agreement L=0EE

Please review the license agreement before installing Adafruit board
drivers. If you accept all terms of the agreement, dick I Agree.

rrhis program will allow you to install Windows drivers for -
hardware that Adafruit Industries produces. Please support
Adafruit by purchasing hardware from:
<http://www.adafruit.com/>

I
Note you can uninstall any of the installed drivers by using i
the Add/Remove Programs option in Control Panel (look for
the "Windows Driver Package' entries from Adafruit).
-

|
Cancel tullsaft Install Swstem w3, 003

Select which drivers you want to install, we suggest selecting all of them so you don't have to do this again!
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start the installation.

* Check the board drivers below that you would like to install. Click install to

Select board drivers to install: Feather 32u4, Feather MO, Feather MO Ex
Feather WICED
Trinket / Pro Trinket / Gemma (USBtinyISP)
[ Arduino Gemma
[[] Feather HUZZAH ESP8266 (SiLabs CP210x]
[]Metro 328 / Metro Mini 328 (FTDI VCP and

LI P 3
Cancel | Mullsoft Tnskall Syskem 3,02, 1 < Back | Install I

On Windows 7, by default, we install a single driver for most of Adafruit's boards, including the Feather 32u4, the
Feather MO, Feather MO, Express, Circuit Playground, Circuit Playground Express, Gemma MO, Trinket MO, Metro MO
Express. On Windows 10 that driver is not necessary (it's built in to Windows) and it will not be listed.

The Trinket / Pro Trinket / Gemma / USBtinyISP drivers are also installed by default.

You can also, optionally, install the Arduino Gemma (different than the Adafruit Gemma!), Huzzah and Metro 328

drivers.

Click Install to do the installin'.

Note that on Windows 10, support for many boards is built in. If you end up not checking any boxes, you don't

need to run the installer at all!

sk Adafruit Board Drive: mmﬁa_[gﬂlg

Show details |

Cancel | Mullsoft Install System w3, 0b3 = Back |

Manual Driver Installation

If windows needs the driver files (inf/cat) for some reason you can get all the drivers by downloading the source code

Latest Adafruit Windows Drivers release
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https://github.com/adafruit/Adafruit_Windows_Drivers/releases/latest

https://adafru.it/ABO

And point windows to the Drivers folder when it asks for the driver location
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Setting up with Arduino IDE

Chances are, you picked up a Trinket because it is programmable with the Arduino IDE. Note that the Trinket is not a
full Arduino-compatible, it uses a different (smaller) chip than the Uno, Mega, Leonardo or Due. However, there are
many small sketches and libraries that will work just fine. Some may not even need anything other than pin number
changes.

Even though Trinket has a USB connector, it does not have a "Serial Console" capability, so you cannot use

Serial to send and receive data to/from a computer! It will not show up as a PORT in the setup menu

Arduino IDE Setup

Just follow the steps in the steps in the Adafruit Arduino IDE setup guide to easily add support for Trinket, Gemma,
Pro Trinket & more to the Arduino IDE.

You will need Arduino IDE 1.6 or greater

When you're finished installing the IDE & board manager add on come back to this page to continue the Trinket guide.

Blink!

After installing the Arduino IDE with support for Adafruit's boards you can load a simple blinking LED example to test
uploading to Trinket works as expected. Open the Arduino IDE and replace the sketch code with the following blink
code:

If you are using Linux you may have to be "root" running the Arduino program to have access to the USB port

(or add udev exceptions)
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/*
Blink
Turns on an LED on for one second, then off for one second, repeatedly.

This example code is in the public domain.

To upload to your Gemma or Trinket:
1) Select the proper board from the Tools->Board Menu
2) Select USBtinyISP from the Tools->Programmer
3) Plug in the Gemma/Trinket, make sure you see the green LED 1lit
4) For windows, install the USBtiny drivers
5) Press the button on the Gemma/Trinket - verify you see
the red LED pulse. This means it is ready to receive data
6) Click the upload button above within 10 seconds
*/

int led = 1; // blink 'digital' pin 1 - AKA the built in red LED

// the setup routine runs once when you press reset:
void setup() {
// initialize the digital pin as an output.
pinMode(led, OUTPUT);

// the loop routine runs over and over again forever:
void loop() {

digitalWrite(led, HIGH);

delay(1000);

digitalWrite(led, LOW);

delay(1000);

Select the Trinket 8MHz board from the Tools->Board menu

& GemmaBlink_8MHz | Arduino 1.0.5 =)
File Edit Sketch |Tools| Help
Auto Format Ctrl+T
Archive Sketch
GemmaBlink | g Fncoding & Reload
* Serial Monitor Crl Shift+ M -1
Elink (A
Turns on an Board 3 Adafruit Gemma 8MHz
) Serial Port b @  Adafruit Trinket 8MHz
Thiz exampl —
Adafruit Trinket 16MHz
Programmer 2
To upload © 0 . Arduino Uno

Then, select USBtinyISP from the Tools->Programmer sub-menu

When you're ready to upload, make sure the "Programmer" in the Tools menu is set to USBtinyISP!
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r )
GemmaBlink 8MHz | Arduing 105 o e =S
File Edit Sketch [Tools] Help
Auto Format Ctrl+T
Archive Sketch
Gemmaglink_ Fix Encoding & Reload
o Serial Monitor Ctrl+ Shift+M ol
Elink
Turns on an Board p [ one zecond, repeatedly.
i 3
This exempl Serial Port
Programmer 4 AVR ISP
To upload t =
1) Select tl Burn Bootloader AVERISP mkl
2] Zelect USBrinyISP from the Tools->Programws @ | USBtinyISP
3) Plug in the Gemma/Trinket, make sure you 3§ USBasp
4] For windows, install the U3Etiny driwvers Parallel P I
5] Press the button on the Genma/Trinket - wey arafiel Frogrammer
the red LED pulse. This means it is ready f Arduino as I5P -
6] Click the upload button ahove within 10 seconds

The Serial Port menu will not show the Trinket, that's normal!

Plug in the Trinket, make sure you see the green LED lit (power good) and the red LED pulsing.

Press the button if the red LED is not pulsing, to get into bootloader mode.

Click the Upload button (or select File->Upload)

p-

GemmaElink_8MHz | Arduine 1.0.5

File Edit Sketch Tools Help

GemmaBlink_8hHz

i
Blink

If everything goes smoothly you should see the following (no red error messages) and of course, the red LED on the
trinket will blink on/off once a second
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-

.
GemmaBlink_8MHz | Arduine 105 [ESREEE

File Edit Sketch Tools Help

GemmaBlink_ahHz
Elink -

This example code iz in the public domain.

To upload to your Gemma or Trinket:
1) &elect the proper board from the Tools->Board Merun
2] Zelect UZBLinyI3P from the Tools->Programmer
3) Plug in the Gemma/Trinket, make sure you see the green LED lit
4] For windows, install the U3Etiny driwvers
5) Press the button on the Genma/Trinket - werify you see
the red LED pulse. This means it is ready to receiwve data
|5] Click the upload button above within 10 seconds
i

m

int led = 1; /¢ blink 'digital' pin 1 - AK&4 the built in red LED

/4 the setup routine runs once when you press reset: o

€ | [T | »

Adafruit Trink

Something Went Wrong!

Turns on an LED on for one second, then off for one second, repeatedly.—

If you get the error message avrdude: Error: Could not find USBtiny device (0x1781/0xc9f)

That means the bootloader wasn't active. Make sure to press the button on the Trinket to activate the bootloader
before clicking the Upload button.
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GemmaBlink_8MHz | Arduine 1.0.5 L =|ulEl ﬁ

File Edit Sketch Tools Help

GemmaBlink_ahHz
J.i'*
Elink
Turns on an LED on for one second, then off for one second, repeatedly.

»

Thisz example code iz in the public domain.

m

To upload to your Gemma or Trinket:

1) Zelect the proper board from the Tools->EBoard Memn N
21 GSelect USBLinyISP from the Tools->Programmer
3) Plug in the Gemma/Trinket, make sure you see the green LED lit —

4] For windows, install the USEtiny driwvers

%) Press the button on the Gemma/Trinket - werify you see
the red LED pulse. This means it is ready to receive data

5] Click the upload button above within 10 seconds

*

int led = 1; // blink 'digital' pin 1 - AFA the built in red LED

< | i 3

Adafruit Trink

If you get a lot of red text, errors and also a warning about Verification Failed

Try again! Make sure you have a good USB cable, try connecting through a hub if you have one.
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GemmaBlink_ahHz

3) Plug in the Gemma/Trinket, make sure you see the green LED lit -
4] For windows, install the U3Etiny driwvers
5) Press the button on the Genma/Trinket - werify you see
the red LED pulse. This wmeas 1t is ready to receive data
6] Click the upload button above within 3 seconds
i

int led = 1; /¢ blink 'digital' pin 1 - AK&4 the built in red LED

/4 the setup routine runs once when you press reset:
void setup () {
/4 initialize the digital pin as an output.
pintode (led, OUTPUT) :

m

A4 the loop routine runs owver and owver again forewver:
vold loop () !

digitallWlrite|led, HIGH):

delay(l000) ;

Adafruit Trinke

On Linux if you get the error message "usbtiny_receive: error sending control message:
Protocol error (expected 4, got -71)"

These can generally be ignored and should not interfere with the program upload. Unfortunately Linux's USB core is a
little flakey communicating with the ATtiny85 processor on the Trinket/Gemma and can cause these errors. If an
upload does fail, try it again as it is likely an intermittent issue.
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Programming with Arduino IDE

Once you've gotten the basic Blink example to work, you can try some of the other Arduino functions and libraries.
We'll be filling out this section with more example code and links to tutorials - this is just to get you started!

pinMode() & digitalWrite() & digitalRead)

You can use pinMode() to make inputs and outputs on any of digital pins #0 thru #4
digitalWrite also works well, and you can also use it with pinMode(INPUT) to activate the internal pull-up resistor on a

pin

For example, to set up digital #0 as an input, with an internal pullup, and then check if it is being pulled to ground via a
button or switch and turn on the red LED when it is pressed:

/*
Button
Turns on an LED when a switch connected from #0 to ground is pressed

This example code is in the public domain.

To upload to your Gemma or Trinket:
1) Select the proper board from the Tools->Board Menu
2) Select USBtinyISP from the Tools->Programmer
3) Plug in the Gemma/Trinket, make sure you see the green LED 1lit
4) For windows, install the USBtiny drivers
5) Press the button on the Gemma/Trinket - verify you see
the red LED pulse. This means it is ready to receive data
6) Click the upload button above within 10 seconds
*/

#define SWITCH 0
#define LED 1

// the setup routine runs once when you press reset:
void setup() {
// initialize the LED pin as an output.
pinMode(LED, OUTPUT);
// initialize the SWITCH pin as an input with a pullup
pinMode(SWITCH, INPUT PULLUP);

// the loop routine runs over and over again forever:
void loop() {
if (! digitalRead(SWITCH)) { // if the button is pressed

digitalWrite(LED, HIGH); // light up the LED
} else {
digitalWrite(LED, LOW); // otherwise, turn it off

}

analogRead()

You can read an analog voltage from digital #2 (called Analog 1), digital #3 (called Analog 3) and digital #4 (called
Analog 2)
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For example, to read an analog voltage on pin #2, you would call analogRead(1) to read an analog voltage on pin #4

call analogRead(2)

This is a bit confusing because the analog pins are numbered differently than the digital pins!

analogWrite()

There are a few PWM outputs on the Trinket, you can call analogWrite() on digital #0, #1 and #4.

For example, to pulse the built-in LED slowly, upload this code:

/*
Pulse
Pulses the internal LED to demonstrate the analogWrite function

This example code is in the public domain.

To upload to your Gemma or Trinket:
1) Select the proper board from the Tools->Board Menu

2) Select USBtinyISP from the Tools->Programmer

3) Plug in the Gemma/Trinket, make sure you see the green LED 1lit
4) For windows, install the USBtiny drivers

5) Press the button on the Gemma/Trinket - verify you see

the red LED pulse. This means it is ready to receive data
6) Click the upload button above within 10 seconds
*/

int led = 1; // pulse 'digital' pin 1 - AKA the built in red LED

// the setup routine runs once when you press reset:
void setup() {
// initialize the digital pin as an output.
pinMode(led, OUTPUT);
}

// the loop routine runs over and over again forever:
void loop() {
for (int i=0; i<256; i++) {
analogWrite(led, i); // PWM the LED from O to 255 (max)
delay(5);
}
for (int i=255; i>=0; i--) {
analogWrite(led, i); // PWM the LED from 255 (max) to O
delay(5);
}

Make sure you're using the latest Trinket IDE so you can access pin #4's PWM capabilities. If you aren't using the
latest IDE you need to manually add functions like the following to init and write analog values to pin #4. However if

you have the latest IDE it includes fixes to make pin #4 usable with Arduino's analogWrite function!
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void PWM4 init() {

// Set up PWM on Trinket GPIO #4 (PB4, pin 3) using Timer 1
TCCR1 = _BV (CS10); // no prescaler

GTCCR = BV (COM1B1l) | _BV (PWM1B); // clear OC1B on compare
0CR1B 127; // duty cycle initialize to 50%

OCR1C = 255; // frequency

}

// Function to allow analogWrite on Trinket GPIO #4
void analogWrite4(uint8 t duty value) {

OCR1B = duty value; // duty may be 0 to 255 (0 to 100%)
}

Wire (i2¢)

You can use 12C with the Trinket! If you have our board manager package v1.6.4 or later (thats the version of the trinket
support package, not IDE) then Wire will work on Attiny85

On the Trinket boards, pin #0 is SDA (12C data), pin #2 is SCK (I12C clock).

More...

We also know the following libraries work:

e Adafruit NeoPixel - control up to 00 Neopixels via a Trinket!
e SoftwareSerial - the built in SoftSerial library can (at least) transmit data on any digital pin.
® More as we do more testing and verification!
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Programming with AVRdude

For more technical users, rather than using the Arduino IDE, they may want to program the Trinket directly with AVR-
GCC as the compiler, vi/emacs as their editor and AVRdude as the uploader. That's easy to do!

Target the Attiny85 as the chip used in avr-gcc, with F_CPU at 8MHz using the internal oscillator.

To use avrdude a minor change must be made to to avrdude.conf. To figure out where the avrdude.conf is, open up a
command window (windows: cmd, mac: Terminal, linux: rxvt etc) and type in avrdude -v

-

BN C\Windows\system32\cmd.exe | | (5 |

2islUserssladyada>avrdude —v

avrdude : Uersion 5. compiled on 3:18:15
Copyright 26 28005 Bri D ‘W bdmicro .comns
Copyright 2 889 Joerg YWun

ation fFile is "C:“Program Files <(xB&6>~MHU AUR Tools
“Jhinsaved

avrdude: no programmer has been specified on the command line or the config file

Specify a programmer using the —-c option and try again

IC:sUserssladyada

Look for the line System wide configuration file is ..... thats where avrdude.conf is.
Because the USB bootloader is a little different than an off-the-shelf programmer, we have to update the configuration

file to have a longer erase delay. This does not affect programming bare Attiny85 chips, so you can use this
configuration file with Trinkets or raw chips without any problems.

The Short Way

Download the new avrdude.conf by clicking on the button, rename the old avrdude.conf file to avrdudeconf.bak and
copy this new one into the same directory

This may not work if you're not running the exact same version of avrdude that we are, in which case, just go down to
"the long way" (its really not that long)

https://adafru.it/cDZ

A slightly different configuration file is needed for Mac:

https://adafru.it/cEx

You can also find a Linux version of the avrdude.conf file here:
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http://learn.adafruit.com/system/assets/assets/000/010/752/original/avrdude.conf?1378151630
http://learn.adafruit.com/system/assets/assets/000/010/824/original/avrdude.conf?1378681026

avrdude.conf (Linux version)

https://adafru.it/dXe

The Long Way

If you want to update your avrdude.conf by hand, its not too hard.

Open up that exact file in your favorite text editor

l:' avrdude.conf - XEmacs =&
File Edit View Cmds Tools Options Buffers Help

Diw @SBB8 R i P e

Open | Dired | Sawe | Print | Cut | Copy Undo | Spell | Replace Compile Hdams

avrdude.conf
§$Id: avrdude.conf.in 1012 2011-09-15 14:57:51Z joerg wunsch § -%- text -*- il

AVRDUDE Configuration File

This file contains configuration data used by AVRDUDE which describes
the programming hardware pinouts and also provides part definitions.

AVRDUDE's "-C" command line option specifies the location of the
configuration file. The "-c" option names the programmer configuration
which must match one of the entry'a "id" parameter. The "-p" option
identifies which part AVRDUDE is going to be programming and must match
one of the parts' "id"™ parameter.

Posszible entry formats are:

pProgrammer
id = <idl> [, <id2> [, <id3>] ...] ; # «<idN> are quoted strings
desc = Ldescription> ; $# quoted string
type = par | stk500 | =2tk500v2 | =tk5S00pp | stkS00hvap | 5tk500qen=€5’

ric |

e =Tl AN 1 B Tt ] oAt At al e L]

Raw--%%-XEmacs: avrdude.conf [{Text PenDel)————L1——TOfr—— = e e e

lil'..::lad.i.ng efs-cu...done

and find the following text

#
# ATtiny85
#
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https://github.com/adafruit/Trinket_Arduino_Linux/raw/1.0.5/arduino-1.0.5/hardware/tools/avrdude.conf

r  — . [ e
X owdecont-XEmacs [ P
File Edit View Cmds Tools Options Buffers Help
-
D= R o bBZ8Rei e
Open | Dired | Sae Print Cut Copy | P Uindo Spell | Replace | bl info | Compile| Dn fews
avrdude.conf
(=}
memory "calibration”™
size = 2:
read ="p 0 1 1 i1 0 0 0 000 x xxx x",
"0 0 0 O 0 0 0 a0 oooQ o00e";
’
By S
# ATcinyas|
S
part —
id = WgB8s™;
desc = "ATtinyBS5S";
has_debugwire = yes;
flash_instr = 0xB4, 0x02, O0x12;
eeprom_instr = OxBB, OxFF, OxBB, OxEE, OxBB, 0xCC, OxB2, 0x0D, h
0xBC, 0Ox02, OxB4, 0Ox02, OxBA, 0x0D, OxBB, O0xBC, =
e M Mi=eDD NieeWi™ o —
Raw—-%i-XEmacs: avrdude.conf {Text PenDel Iaearch)----L10B80——-66%——-—————-
T-search: attinyB85

Delete the text after the Attiny85 header text starting with part and onto until the next header (in ours, that was

ATmega640

3 srivsecort- Xorucr s L o=

Iﬁle Edit View Cmds Tools Options Buffers Help
ABs . L
D e B B8 %o @6
Open | Dired | Sew | Print | cCut | copy | P Undo | Spell | Replace | i info | Compile| D Higws
avrdude.conf
size =2; =
read ="y 0 1 1 i 0 0 0 000 x xxx x",
"0 0 0 0 o 0 0 a0 coeoo o0oe";
ATItiny85
|
ATmega&40
Almost same as ATmegal2B80, except for different memory sizes 1
L
part
id = "me40";
desc = "ATMEGA&40™;
signature = 0Oxle 0x%& Ox0B; 5
has_Jjtag = yes: B
# 5tk500_devcode = 0xB2:
* eI A Anrroe e — MNwADa ;-
Raw--*+*-¥Fmacs: avrdude.conf {(Text PenDel)----L10B82-—-6T7%————-——————mm— e

Then paste in the following in the spot where you just deleted!

part
id = "t85";
desc = "ATtiny85";
har AAahiimiis vma — vsAam
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Ias>_ucuvuywliic = yco,
flash instr 0xB4, 0x02, 0x12;
eeprom _instr 0xBB, OxFF, 0xBB, OxEE, 0xBB, 0xCC, 0xB2, 0x0D,
0xBC, 0x02, 0xB4, 0x02, OxBA, 0x0D, 0xBB, 0xBC,
0x99, OxEl, 0xBB, OXAC;
## no STK500 devcode in XML file, use the ATtiny45 one

stk500 devcode = 0x14;
## avr910 devcode =7;
## Try the AT90S2313 devcode:
avr91l0 devcode = 0x20;
signature = Oxle 0x93 0x0Ob;
reset = io;

chip erase delay = 900000;

pgm enable ="1010 1100 01061 66011",
"X X X X X X X X X X X X X X X X";
chip erase ="1010 1100 100 x xxx x",
"X X X X X X X X X X X X X X X X";

timeout = 200;
stabdelay = 100;
cmdexedelay = 25;
synchloops = 32;

bytedelay = 0;
pollindex = 3;
pollvalue = 0x53;
predelay = 1;

postdelay = 1;
pollmethod = 1;

hvsp_controlstack =
0x4C, 0x0C, 0x1C, 0x2C, 0x3C, 0Ox64, 0x74, 0x66,
0x68, 0x78, 0x68, 0x68, Ox7A, Ox6A, 0x68, 0x78,
0x78, 0x7D, Ox6D, 0x0C, 0x80, 0x40, 0x20, 0x10,
0x11, 0x08, 0x04, 0x02, 0x03, 0x08, 0x04, 0x00;

hventerstabdelay = 100;
hvspcmdexedelay = 0;
synchcycles =6;
latchcycles =1;
togglevtg =1;
poweroffdelay = 25;
resetdelayms =1;
resetdelayus = 0;
hvleavestabdelay = 100;
resetdelay = 25;
chiperasepolltimeout = 40;
chiperasetime = 900000;

programfusepolltimeout = 25;
programlockpolltimeout = 25;

memory "eeprom"

size = 512;
paged = no;
page size = 4;

min write delay = 4000;

max write delay = 4500;
readback pl = Oxff;
readback p2 = Oxff;
read ="1 0 1 0 0 0 0 0 000x xx x a8",
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write
loadpage lo = " 1 1
"0 0 0 0
"0 0 0 0
R | i ii
writepage = " 1 1 0
"0 0 X X
"'a7 a6 a5 a4
"X X X X
mode = 0x41;
delay = 12;

blocksize = 4;
readsize = 256;
memory "flash"

paged =
size =
page size =
num_pages =
min write delay =
max_write delay =
readback pl =
readback_p2 =
read lo =

read_hi =

loadpage lo =

loadpage hi =

writepage =
mode = 0x41;
delay = 6;

blocksize = 32;
readsize = 256;

+H AT+43 QR hae Cianatiira

© Adafruit Industries

000 x xxx a8",

"a7 a6 a5 a4 a3 a2 al a0 0000
="1 1 0 0 0 0 0 0
"a7 a6 a5 a4 a3 a2 al al iiii
0 0 0 0 i,
o 0 0 0",
0 al ao",

i i i i";

0 0 0 1 0",

X X x a8",
a3 a2 0 0",

X X X x";

yes;

8192;

64;

128;

30000;

30000;

Oxff;

Oxff;

"0 0 1 0 o 0 0 0",
"0 0 0 0 all alo a9 a8",
"'a7 a6 a5 a4 a3 a2 al alf",
] o] o] 0 o] o] o] o";
"0 0 1 0 1 0 0 0",
"0 0 0 0 all ald0 a9 a8",
"'a7 a6 a5 a4 a3 a2 al alf",
"0 0 0 o] 0 0 0 o";
"0 1 0 0 o 0 0 0",
"0 0 0 X X X x",
"X X x a4 a3 a2 al alf",
| i i i i i i i";
"0 1 0 0 1 0 0 0",
"0 0 0 X X X X x",
"X X X a4 a3 a2 al alf",
| i i i i i i i";
"0 1 0 0 1 1 o0 o,

"0 0 0 0 all alo a9 a8",

"a7 a6 a5 x x x x x",

"X X X X X X X X"

RDut+ncs NAVIE NAvO2 NAvNQ

0000";

iiii";
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" A1 LLIIYyUO 110D Jliyliduul ©

memory "signature"

size
read

’
memory "lock"
size
write

min write delay
max_write delay

’
memory "1lfuse"

size
write

read

min write delay
max_write delay

memory "hfuse"

size
write

read

min write delay
max_write delay

’
memory "efuse"

size
write

read

min write delay
max_write delay

memory "calibration"

size
read

If editing manually, Mac users should delete all references to parallel port programmers ("type = par;").

vyLco.

IIO 0
"X X

"10
X X
9000;
9000;

1;
"10
"X X

"0 1
"X X
9000;
9000;

II1 0
"X X

"01
"X X
9000;
9000;

"10
"X X

"0 1
"X X
9000;
9000;

= 2;
=0 0

"o 0

=

Uploading with AVRdude

© Adafruit Industries

UALL

11
X X
0 1
X X
0 1
X X
0
X
01
X X
1
X
0 1
X X
0
X
11
0 0

UAZJ UAUU.

0 0 0 0
X X al a0
100 11
x 111
100
X x x i i
000
X X
100
X X X i i

100 10
X X X X
0600 000

[c o)
oo

al

ii";

ii";

x i";

00",

0 0",

00,

0 0",

0",
o";

0",

0",

0"

x

X X x x",
0000";

o
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Now you're ready to use avrdude. Open up your command line and enter in this line (but don't hit return)

avrdude -c usbtiny -p attiny85

-

BN C\Windows\system32\emd.exe |ﬂ

% ladyada>avrdude —c¢ ushtiny —p attinyBS

Now plug in the Trinket into the computer's USB port and/or press the reset button to enter the bootloader. You
should see the red LED pulsing. Now press return, you should get the same response as shown here:

BN C\Windows\system32iemd.exe |ﬁ|ﬁ

sUzerssladyada>avrdude —c ushtiny —p attiny8h

vrdude: AUR device initialized and ready to accept instructions

Reading | HHHBUERBHERAHERNUHERAHERARREBURNHERANERRUHERAHRRARNE | 108 B.82s
avrdude : Device signature = Bxle?38b

avrdude : femode: Fu OK

wirdude done. Thank you.

C:sUserssladyadar

If you get the response
avrdude: Error: Could not find USBtiny device (0x1781/0xc9f)

the bootloader is not active, make sure you see the red LED pulsing, press the reset button to start the bootloader
again.

Programming in a Blink example

For more details on using avdude and avr-gcc, you'll need to read a detailed tutorial or book on those subjects.
However, you can do a basic test by uploading the following HEX file, which will blink the #1 LED once a second on
and off. (Its a bit chunky as blink.hex's go as it has all the Arduino IDE stuff in there too. If you wrote it in straight-C it
would be like 100 bytes) - if you want to see the source code for this, it's basically the Arduino file->examples->basics-
>blink demo with 1 as the LED pin

Click the button to download it and place it in the same directory as your command prompt, in these screenshots that's
C:\Users\ladyada
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And uploading it with the command avrdude -c usbtiny -p attiny85 -U flash:w:trinketblink.hex
or, if that's giving errors, avrdude -c usbtiny -p attiny85 -D -U flash:w:trinketblink.hex (note the extra -D)

As before, type out the command, then press the reset button to start the bootloader and once the red LED is pulsing,

hit return

When uploading, you will see a lot of avrdude: 8 retries during SPI command and similar warnings. THIS IS OK!
Because of the way the ATtiny85 works, there's a small delay when writing the new program to flash, and during that
delay, it cannot save the data and also send USB data at the same time. This causes the USB reply to avrdude to be

delayed and avrdude to spit out the retry alert.

R — "
E Select CAWindows\system32\c
: e e

CaslUser adyadazavrdude —c ushtiny -p attinyBS -U flas

wrdude: Device ature Ax1e?38b

To disahle 1‘I|.i... feature, specify the -D option.
vrdude :
ude : ¥ hlink.hex"

avrdude: writing I'-"lafh <832 'hgl'F >

Writ HE 21080

8 retries during SPI command
Writin nHugnUy

| 8 during SPI command

SPl command
HRHBRE RN R
; during SPI command
EETEE R IR R E R R
: durding SPI command
pEEEBEERTAS BEES RS
: during SPl command
ﬂﬂﬂﬁﬂﬂﬂﬂﬁﬂﬂﬂﬁﬂﬂﬂﬂﬁﬂﬂﬂﬁﬂﬂﬂﬂﬁ
es during SPI command
CERE R R R R R R R IE BRI B R
during SPI command
fidigibidiaidiaiden edidadin digidud kg adin beg R n g idin bhE
: during SPI command
i ﬂﬂﬂﬁﬂﬂﬂﬁﬂﬂﬂﬂﬁ“ﬂﬂﬁﬂﬂﬂﬂﬁ“ﬂﬂﬁﬂﬂﬂﬂﬁﬂﬂ
during S5PI command
“#HﬂﬂHﬂﬂ#ﬂ#ﬂﬂﬂH#H#HﬂﬂﬂﬂH#H#Hﬂﬂﬂ#ﬂ#ﬂﬂﬂ#ﬂﬂ#ﬂ
during SPI command
nnnnunannnnnnunannununuunnnunanannnnunaunnnnnu

during SPI comnmand

trinkethlink. hex

avrdude : AUR device initialized and ready to accept instructions

Reading | #EHBRBREREAHBERRAGHARBEARERERRHERARHBRARBRARABRAARAR | 1606 B.802s

avrdude: NOT 'F]'ﬂ H memory has been specified. an erase cycle will be performed

..unt]lLLlL .1.||1_1u|' h ¢ auto detected as Intel Hex

T B.Bdsavrdude:
15x B.B8¥savrdude :
23% B.14savrdude:
38

.28savrdude:
33savrdude :
37zsavrdude =
2savrdude
~A7?savrdude =

84 B.52savrdude:

i 92% B.5Vsavrdude =

HEHBHNBHRHAHERIOH RSB R RN RN R R B RIRHE | 198 B.625

against tri 2
flash data from input file trin

1 in
lavrdude = ing file trinkethlink.hex auto detected Intel He

sdude = 1 file trinkethlink.h contains B32 bytes
lavrdude : reading on—chip flash da

-Reaﬂinq | RHRHEREREREHERARERERRERAHERARERERRBER AR AR RERARE | 106 B.11s

ﬂ
Navirdude : verifyin
javrdude: 832 bytes of flash verified

avrdude: safemode: Fuses OK

vrdude done. Thank you.

Userssladyada
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16MHz vs 8MHz Clock

The Trinket by default runs at 8 MHz, a plenty fast speed for nearly all of your microcontroller needs. However, you
may want to use code that requires it to run at 16 MHz, or maybe you just want a little boost in speed.

The 16 MHz clock speed is for Trinket 5V only!

The ATtiny85 is only specified to run at 16 MHz when powered at 5V - that means that officially you can only run the
5V Trinket at 16 MHz.

However, the AVR series is pretty forgiving for overclocking, so you may be able to run the 3V Trinket at 16 MHz Note
that this is still overclocking, your code may run flakey or not at all!l Overclocking should not damage the AVR, but we
still recommend sticking with 8 MHz only for the 3V version, and 8 or 16MHz only on the 5V version.

Power Tradeoffs

Doubling the speed will increase the power usage just a bit. At 8 MHz the current draw is about 9 milliamps. That
number includes the green power LED which draws about 3mA so thats 6mA for the microcontroller itself.

At 16 MHz the draw is 12mA total. Subtracting the green LED current draw, that means 9mA for the microcontroller
itself.

How to activate the 16 MHz clock
...on AVR-GCC

We can activate the 16MHz clock 'in software' simply by asking the chip to set the clock prescale. If you are using raw
avr-gcg, run this as the first line in main()

clock_prescale_set(clock_div_1);

You may need to add #include to your file so that the commands are recognized. Then make sure to compile your
code with F_CPU =16000000

...Arduino IDE

Using 16 MHz mode is very similar when using the Arduino IDE. Add the following line to the very top of your Arduino
sketch (as the first line)

#include <avr/power.h>

Then, in setup() - add this as the first line in the function:

if (F_CPU ==16000000) clock_prescale_set(clock_div_1);

Then select Trinket 16MHz from the Tools->Board menu. Your code will compile and run at 16 MHz!
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GemmaBlink_16MHz | Arduino 1.0.3

File Edit Sketch [Tools| Help

Auto Format Ctrl+T
Archive Sketch
Gemmaglink_ Fix Encoding & Reload
Serial Monitor Ctrl+Shift+M
int led = 0; uilt in red LED
Board 3 Adafruit Gemma BMHz
th =
J/ the setup Serial Port ¥ Adafruit Trinket 8MHz
void setup ()
/4 Thiz is @ Adafruit Trinket 16MHz
Programmer 3
| A4 antnmari

Arduina | lns

© Adafruit Industries https://learn.adafruit.com/introducing-trinket Page 35 of 43



Repairing bootloader

The ATtiny85 does not have a protected-bootloader section. This means its possible to accidentally overwrite the
bootloader (or even if you unplug the Trinket while uploading it might have difficulties from then on)

You can use an Arduino UNO to re-program the bootloader onto your Trinket (or Gemma). This loader isn't tested to
work with any other kind of Arduino.

Connect:

Trinket VBAT+ pin to Arduino 5V (or just power it via a battery or USB cable)
Trinket GND pin to Arduino GND

Trinket RST to Arduino #10

Trinket #0 pin to Arduino #11

Trinket #1 pin to Arduino #12

Trinket #2 pin to Arduino #13

On a Gemma, alligator clips work well. the Reset pin is underneath the MiniUSB Jack. You may have to solder a wire
temporarily. Alternatively, sometimes you can just hold the reset button down while running the sketch (type 'G' to
start) and it might work. Soldering a wire works best.

Then download, uncompress and run the Trinketloader sketch, pick the one that matches your Arduino version!

trinketloader_2015-06-09.zip

https://adafru.it/fmg

Uncompress and open in the Arduino IDE, select the UNO and serial port to the UNO Arduino board you are uploading
too and upload it to the UNO.

Open up the serial console at 9600 baud and when it tells you to, press the miniature button on the Trinket (or
Gemma) or type in G into the serial console and click Send

You should see the following, the fuses, firmware burned and verified! It will take 2 seconds
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ORI
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If you keep getting "Failed to verify fuses" while trying to restore the bootloader on a 3.3V Trinket using a

Duemilanove. Try connecting 5V to the 3V pin on the Trinket, not VBAT+. Make sure USB is not plugged into the

Trinket when you do this. Its a bit of a hack but may help!
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Downloads
Datasheets

® Datasheet for the onboard regulator used (MIC5225 3.3V and 5.0V)
e Webpage for the ATtiny85, the microcontroller used in the Trinket

Source code

e Original code for the Trinket/Gemma bootloader on github - We do not offer any support for this code, it is
released as-is!

e PCB files for both Trinkets - you can use this to get more dimensions or part details, they are the fabrication files

® Fritzing object in the Adafruit Fritzing Library

Please note: you cannot use the Adafruit USB VID/PID for your own non-Trinket/Gemma products or projects.

Purchase a USB VID for yourself at

Schematics
Click to embiggen
Trinket 3.3V Schematic:
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Trinket 5V schematic
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Newer Trinket (Micro USB) dimensions

These are the same for the 3V and 5V versions

The following shows measurements in mm, both version of the Trinket have the exact same dimensions for hole
placement & outline

For more dimensions or if something is missing you need, check the Eagle CAD files above which will give you the
location of every component and hole!
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Older Trinket (Mini USB) dimensions

These are the same for the 3V and 5V versions
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FAQ

How come | can't find the Trinket Serial (COM) Port? Why is no Serial port found when the Trinket is plugged in?
Trinket (and Pro Trinket) do not have a USB-serial converter chip on board, this is how we can make them so small!
Instead of a serial console, the Trinket is programmed directly over USB. No COM/Serial port is used at all!

I'd like to use Trinket with Linux....

We don't guarantee Linux support since Linux varies from distro to distro, but here's a very nice tutorial about
Trinket with Ubuntu 14)

| can't seem to upload to my Trinket when it's plugged into a USB 3.0 port (newer Macbooks have USB 3 ports)
Trinket's bootloader is finicky about USB 3 ports, and might not work on them. Try connecting to any USB 2 ports
you have or go through a USB 1 or USB 2 hub (nearly all hubs are v2 or v1 instead of v3)

My Trinket 16MHz can't control servos, NeoPixels, but the code is uploading OK?

Sounds like the Trinket thinks its running at 8MHz but the Arduino software thinks it's running at 16MHz, this causes
timing-specific stuff like Servos and NeoPixels to not work. Don't forget you must turn on 16MHz speedup if you are
uploading to "Trinket 16MHZz"

Do so by adding

#include <avr/power.h>

At the very top of your sketch, and then

if (F_CPU == 16000000) clock_prescale_set(clock_div_1);
first thing in setup()

See more details here

Hmm I'm still having problems with Avrdude - and | definitely did the required updates
One fix that works for some people is to edit avrdude.conf and set the

chip_erase_delay = 900000;
under the ATtiny85 heading to
chip_erase_delay = 400000;

That is, a shorter delay.

Can Trinket driver Neopixels (strips, squares, etc)? How many?

Yes! Trinket was designed to drive short segments of NeoPixels. There is enough RAM on the attiny85 to drive 100
pixels, but depending on program RAM usage you may have to scale back to 60 or 40.

You can use EITHER the 3V or 5V Trinket, at EITHER 8 or 16 MHz!
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To use with neopixels:

1. Connect the + power line of the strip to VBUS (5V from USB), to VBAT if you are powering the Trinket with 4-
7VDC, or to a separate 4-7VDC power source such as a 3 or 4 pack of AA batteries.

2. Connect the - common ground to the battery pack (if being used) and also to the Trinket GND pin

3. Connect the data in line to Trinket #1 - this will let you also see when data is being sent because the #1red
LED will flicker. You can use other pins but start with #1 since its easiest to debug and use

4. Install the NeoPixel library as detailed in our Uber Guide, and change the PIN to 1 (its 6 by default)

5. Upload and enjoy!

Can the Trinket drive your Adafruit 12C LED Backpacks for 7-segment/matrix displays?
Short answer: yes! Check out http://learn.adafruit.com/tap-tempo-trinket for a tutorial on driving the 7-segment
displays. Long answer: we think there's not enough space for all of the fonts for the 8x8 so you might be able to
drive the 8x8 matrix in 'raw' mode (see the HT16K33 example sketch in the LEDBackpack Library) but unfortunately
not with built-in font support.

That tutorial also shows how to use the TinyM I2C driver, which works great on the ATtiny85, and adapt other
existing libraries for the Trinket

Can Trinket drive a Servo?

Yup! In fact you can use 3 servos as long as they are powered by a good 5V supply, check out this guide for more
details

Why does Windows sound the Connect/Disconnect chimes every ten seconds?

The Trinket only appears to be a USBtinyISP device when the bootloader is running. By design, the bootloader only
runs for 10 seconds and then jumps back to the main user sketch. this causes the 'disconnect' sound.

On a new trinket, the main sketch will automatically jump back to the bootloader, which will then cause the
'connect' sound. This cycle will repeat until a user sketch is loaded.

This situation can also happen if you load a sketch with a bug in it that causes a CPU reset.

Can | power the directly on the 5.0V or 3.3V (e.g. treating those as a power input)?

Technically yes - you can provide regulated 5V or 3.3V directly to the lower right hand power pin. However, the
regulator dropout is quite low, its safer and better to power the VBAT pin since that way you wont be 'fighting' the
USB port if you plug in USB
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